import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?_.*?_.*?)_";
final String string = "john_doe_13456_20_m_v5\n"
+ "john_doe_13456_20_m_n7_abc\n"
+ "john_doe_13456_20_m_t44\n"
+ "john_doe_13456_20_m_m13_bca_1\n"
+ "john_doe_13456_20_m_v5";
final String subst = "\\1 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}