#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*?_.*?_.*?)_"
Local $sString = "john_doe_13456_20_m_v5" & @CRLF & _
"john_doe_13456_20_m_n7_abc" & @CRLF & _
"john_doe_13456_20_m_t44" & @CRLF & _
"john_doe_13456_20_m_m13_bca_1" & @CRLF & _
"john_doe_13456_20_m_v5"
Local $sSubst = "\1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)