import Foundation
let pattern = #"^(.*?_.*?_.*?)_"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
john_doe_13456_20_m_v5
john_doe_13456_20_m_n7_abc
john_doe_13456_20_m_t44
john_doe_13456_20_m_m13_bca_1
john_doe_13456_20_m_v5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)