using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?_.*?_.*?)_";
string substitution = @"\1 ";
string input = @"john_doe_13456_20_m_v5
john_doe_13456_20_m_n7_abc
john_doe_13456_20_m_t44
john_doe_13456_20_m_m13_bca_1
john_doe_13456_20_m_v5";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}