#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!\/)[^\/]+\/?$"
Local $sString = "file:///home/pasta/pasta/img/intro-bg.jpg" & @CRLF & _
"http://www.google.com/m8/feeds/contacts/myemail%40gmail.com/base/nabb80191e23b7d9" & @CRLF & _
"https://regex101.com/r/mblcCW/1/" & @CRLF & _
"https://pt.stackoverflow.com/questions/249556/express%C3%A3o-regular-para-capturar-depois-da-%C3%BAltima-barra"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")