const regex = /(?!\/)[^\/]+\/?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!\\\/)[^\\\/]+\\\/?$', 'gm')
const str = `file:///home/pasta/pasta/img/intro-bg.jpg
http://www.google.com/m8/feeds/contacts/myemail%40gmail.com/base/nabb80191e23b7d9
https://regex101.com/r/mblcCW/1/
https://pt.stackoverflow.com/questions/249556/express%C3%A3o-regular-para-capturar-depois-da-%C3%BAltima-barra`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}