using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\/)[^\/]+\/?$";
string input = @"file:///home/pasta/pasta/img/intro-bg.jpg
http://www.google.com/m8/feeds/contacts/myemail%40gmail.com/base/nabb80191e23b7d9
https://regex101.com/r/mblcCW/1/
https://pt.stackoverflow.com/questions/249556/express%C3%A3o-regular-para-capturar-depois-da-%C3%BAltima-barra";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}