$re = '/(?!\/)[^\/]+\/?$/m';
$str = 'file:///home/pasta/pasta/img/intro-bg.jpg
http://www.google.com/m8/feeds/contacts/myemail%40gmail.com/base/nabb80191e23b7d9
https://regex101.com/r/mblcCW/1/
https://pt.stackoverflow.com/questions/249556/express%C3%A3o-regular-para-capturar-depois-da-%C3%BAltima-barra';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);