import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!\\/)[^\\/]+\\/?$";
final String string = "file:///home/pasta/pasta/img/intro-bg.jpg\n"
+ "http://www.google.com/m8/feeds/contacts/myemail%40gmail.com/base/nabb80191e23b7d9\n"
+ "https://regex101.com/r/mblcCW/1/\n"
+ "https://pt.stackoverflow.com/questions/249556/express%C3%A3o-regular-para-capturar-depois-da-%C3%BAltima-barra";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}