using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([^\n:#]*)(?::([^\n#]+))?)(?:#([0-9A-Za-z]+)(?:\((\d+\.?\d*)\))?)?";
string input = @"Phospho#g1
Glycan:Hex
Glycan:Hex#g1(0.10)
#AAA
#AAA(0.10)
Formula:C6H10O5";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}