const regex = new RegExp('(([^\\n:#]*)(?::([^\\n#]+))?)(?:#([0-9A-Za-z]+)(?:\\((\\d+\\.?\\d*)\\))?)?', 'g')
const str = `Phospho#g1
Glycan:Hex
Glycan:Hex#g1(0.10)
#AAA
#AAA(0.10)
Formula:C6H10O5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}