import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([^\\n:#]*)(?::([^\\n#]+))?)(?:#([0-9A-Za-z]+)(?:\\((\\d+\\.?\\d*)\\))?)?";
final String string = "Phospho#g1\n"
+ "Glycan:Hex\n"
+ "Glycan:Hex#g1(0.10)\n"
+ "#AAA\n"
+ "#AAA(0.10)\n"
+ "Formula:C6H10O5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}