#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)\{(?:[^{}]|(?R))*\}"
Local $sString = "{"id":0,"name":"Ninja Assassin (2009) [720p] Bluray [filmxy.vip].mp4","size":"682305443"}" & @CRLF & _
"" & @CRLF & _
"{"id":0,"progress":242603704}" & @CRLF & _
"" & @CRLF & _
"{"id":0,"progress":437319904}" & @CRLF & _
"" & @CRLF & _
"{"id":0,"progress":560004744}" & @CRLF & _
"" & @CRLF & _
"{"id":0,"size":682305443,"url":"https://uptobox.com/krafbomfc1qm","deleteUrl":"https://uptobox.com/krafbomfc1qm?killcode=7jgnrwn5fu"}" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")