// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)\{(?:[^{}]|(?R))*\}").unwrap();
let string = "{\"id\":0,\"name\":\"Ninja Assassin (2009) [720p] Bluray [filmxy.vip].mp4\",\"size\":\"682305443\"}
{\"id\":0,\"progress\":242603704}
{\"id\":0,\"progress\":437319904}
{\"id\":0,\"progress\":560004744}
{\"id\":0,\"size\":682305443,\"url\":\"https://uptobox.com/krafbomfc1qm\",\"deleteUrl\":\"https://uptobox.com/krafbomfc1qm?killcode=7jgnrwn5fu\"}
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}