import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(?:[^\\{\\}]|(?R))*\\}";
final String string = "{\"id\":0,\"name\":\"Ninja Assassin (2009) [720p] Bluray [filmxy.vip].mp4\",\"size\":\"682305443\"}\n\n"
+ "{\"id\":0,\"progress\":242603704}\n\n"
+ "{\"id\":0,\"progress\":437319904}\n\n"
+ "{\"id\":0,\"progress\":560004744}\n\n"
+ "{\"id\":0,\"size\":682305443,\"url\":\"https://uptobox.com/krafbomfc1qm\",\"deleteUrl\":\"https://uptobox.com/krafbomfc1qm?killcode=7jgnrwn5fu\"}\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}