use strict;
my $str = '{"id":0,"name":"Ninja Assassin (2009) [720p] Bluray [filmxy.vip].mp4","size":"682305443"}
{"id":0,"progress":242603704}
{"id":0,"progress":437319904}
{"id":0,"progress":560004744}
{"id":0,"size":682305443,"url":"https://uptobox.com/krafbomfc1qm","deleteUrl":"https://uptobox.com/krafbomfc1qm?killcode=7jgnrwn5fu"}
';
my $regex = qr/\{(?:[^{}]|(?R))*\}/xp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}