#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<path>/wp-content.+)\.(png|jpeg|jpg)$"
Local $sString = "/dir/wp-content/file.jpg" & @CRLF & _
"/wp-content/file.jpg" & @CRLF & _
"/dir/wp-content/file.png" & @CRLF & _
"/wp-content/file.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")