package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<path>/wp-content.+)\.(png|jpeg|jpg)$`)
var str = `/dir/wp-content/file.jpg
/wp-content/file.jpg
/dir/wp-content/file.png
/wp-content/file.png`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}