using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<path>/wp-content.+)\.(png|jpeg|jpg)$";
string input = @"/dir/wp-content/file.jpg
/wp-content/file.jpg
/dir/wp-content/file.png
/wp-content/file.png";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}