$re = '`^(?<path>/wp-content.+)\.(png|jpeg|jpg)$`m';
$str = '/dir/wp-content/file.jpg
/wp-content/file.jpg
/dir/wp-content/file.png
/wp-content/file.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);