const regex = new RegExp('^(?<path>/wp-content.+)\\.(png|jpeg|jpg)$', 'gm')
const str = `/dir/wp-content/file.jpg
/wp-content/file.jpg
/dir/wp-content/file.png
/wp-content/file.png`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}