re = /^(?<path>\/wp-content.+)\.(png|jpeg|jpg)$/m
str = '/dir/wp-content/file.jpg
/wp-content/file.jpg
/dir/wp-content/file.png
/wp-content/file.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end