#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)href="(/player/[^"]+)""
Local $sString = "</span></div></div><a href="/player/harry-kane/108579"><div cursor="pointer" display="flex" class="sc-hLBbgP sc-eDvSVe izqzSd fRddxb">" & @CRLF & _
"" & @CRLF & _
"</span></div></div></div></div></a><a href="/player/heung-min-son/111505"><div cursor="pointer" display="flex" class="sc-hLBbgP sc-eDvSVe izqzSd fRddxb">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")