import Foundation
let pattern = #"href="(/player/[^"]+)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
</span></div></div><a href="/player/harry-kane/108579"><div cursor="pointer" display="flex" class="sc-hLBbgP sc-eDvSVe izqzSd fRddxb">
</span></div></div></div></div></a><a href="/player/heung-min-son/111505"><div cursor="pointer" display="flex" class="sc-hLBbgP sc-eDvSVe izqzSd fRddxb">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)