// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)href="(/player/[^"]+)""#).unwrap();
let string = "</span></div></div><a href=\"/player/harry-kane/108579\"><div cursor=\"pointer\" display=\"flex\" class=\"sc-hLBbgP sc-eDvSVe izqzSd fRddxb\">
</span></div></div></div></div></a><a href=\"/player/heung-min-son/111505\"><div cursor=\"pointer\" display=\"flex\" class=\"sc-hLBbgP sc-eDvSVe izqzSd fRddxb\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}