using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""(/player/[^""]+)""";
string input = @"</span></div></div><a href=""/player/harry-kane/108579""><div cursor=""pointer"" display=""flex"" class=""sc-hLBbgP sc-eDvSVe izqzSd fRddxb"">
</span></div></div></div></div></a><a href=""/player/heung-min-son/111505""><div cursor=""pointer"" display=""flex"" class=""sc-hLBbgP sc-eDvSVe izqzSd fRddxb"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}