import re
regex = re.compile(r"href=\"(/player/[^\"]+)\"", flags=re.MULTILINE)
test_str = ("</span></div></div><a href=\"/player/harry-kane/108579\"><div cursor=\"pointer\" display=\"flex\" class=\"sc-hLBbgP sc-eDvSVe izqzSd fRddxb\">\n\n"
"</span></div></div></div></div></a><a href=\"/player/heung-min-son/111505\"><div cursor=\"pointer\" display=\"flex\" class=\"sc-hLBbgP sc-eDvSVe izqzSd fRddxb\">")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")