use strict;
my $str = '</span></div></div><a href="/player/harry-kane/108579"><div cursor="pointer" display="flex" class="sc-hLBbgP sc-eDvSVe izqzSd fRddxb">
</span></div></div></div></div></a><a href="/player/heung-min-son/111505"><div cursor="pointer" display="flex" class="sc-hLBbgP sc-eDvSVe izqzSd fRddxb">';
my $regex = qr~href="(/player/[^"]+)"~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}