# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^<]*<(?'Element'[^>\s]*)[^>]*>(?'Text'[^<]*)<\\/\1>\s*$/$2/gm;t' <<< " ELEMENT ATTRIB=\"foo\"> inner text </ELEMENT>
< ELEMENT ATTRIB=\"foo\"> inner text </ELEMENT>
< ELEMENT ATTRIB=\"foo\"> inner text </ELEMENT>
<ELEMENT>inner text</FOO>
ELEMENT ATTRIB=\"foo\"> inner text </ELEMENT>
<ELEMENT>inner text</ELEMENT>
<ELEMENT>inner text</ELEMENT>
<ELEMENT>inner text</ELEMENT>
<ELEMENT > inner text </ELEMENT>
<ELEMENT > inner text </ELEMENT>
<ELEMENT > inner text </ELEMENT>
<ELEMENT ATTRIB=\"foo\"> inner text </ELEMENT>
<ELEMENT ATTRIB=\"foo\"> inner text </ELEMENT>"