const regex = new RegExp('^[^<]*<(?\\'Element\\'[^>\\s]*)[^>]*>(?\\'Text\\'[^<]*)<\\/\\1>\\s*$', 'gm')
const str = ` ELEMENT ATTRIB="foo"> inner text </ELEMENT>
< ELEMENT ATTRIB="foo"> inner text </ELEMENT>
< ELEMENT ATTRIB="foo"> inner text </ELEMENT>
<ELEMENT>inner text</FOO>
ELEMENT ATTRIB="foo"> inner text </ELEMENT>
<ELEMENT>inner text</ELEMENT>
<ELEMENT>inner text</ELEMENT>
<ELEMENT>inner text</ELEMENT>
<ELEMENT > inner text </ELEMENT>
<ELEMENT > inner text </ELEMENT>
<ELEMENT > inner text </ELEMENT>
<ELEMENT ATTRIB="foo"> inner text </ELEMENT>
<ELEMENT ATTRIB="foo"> inner text </ELEMENT>`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);