#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[^<]*<(?'Element'[^>\s]*)[^>]*>(?'Text'[^<]*)<\/\1>\s*$"
Local $sString = " ELEMENT ATTRIB="foo"> inner text </ELEMENT> " & @CRLF & _
"< ELEMENT ATTRIB="foo"> inner text </ELEMENT> " & @CRLF & _
" < ELEMENT ATTRIB="foo"> inner text </ELEMENT> " & @CRLF & _
"<ELEMENT>inner text</FOO>" & @CRLF & _
"ELEMENT ATTRIB="foo"> inner text </ELEMENT> " & @CRLF & _
"" & @CRLF & _
"<ELEMENT>inner text</ELEMENT>" & @CRLF & _
" <ELEMENT>inner text</ELEMENT>" & @CRLF & _
" <ELEMENT>inner text</ELEMENT> " & @CRLF & _
"<ELEMENT > inner text </ELEMENT>" & @CRLF & _
"<ELEMENT > inner text </ELEMENT> " & @CRLF & _
" <ELEMENT > inner text </ELEMENT> " & @CRLF & _
"<ELEMENT ATTRIB="foo"> inner text </ELEMENT> " & @CRLF & _
" <ELEMENT ATTRIB="foo"> inner text </ELEMENT>"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)