# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^<]*<(?'Element'[^>\s]*)[^>]*>(?'Text'[^<]*)<\/\1>\s*$"
test_str = (" ELEMENT ATTRIB=\"foo\"> inner text </ELEMENT> \n"
"< ELEMENT ATTRIB=\"foo\"> inner text </ELEMENT> \n"
" < ELEMENT ATTRIB=\"foo\"> inner text </ELEMENT> \n"
"<ELEMENT>inner text</FOO>\n"
"ELEMENT ATTRIB=\"foo\"> inner text </ELEMENT> \n\n"
"<ELEMENT>inner text</ELEMENT>\n"
" <ELEMENT>inner text</ELEMENT>\n"
" <ELEMENT>inner text</ELEMENT> \n"
"<ELEMENT > inner text </ELEMENT>\n"
"<ELEMENT > inner text </ELEMENT> \n"
" <ELEMENT > inner text </ELEMENT> \n"
"<ELEMENT ATTRIB=\"foo\"> inner text </ELEMENT> \n"
" <ELEMENT ATTRIB=\"foo\"> inner text </ELEMENT>")
subst = "$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.