re = /^[^<]*<(?'Element'[^>\s]*)[^>]*>(?'Text'[^<]*)<\/\1>\s*$/m
str = ' ELEMENT ATTRIB="foo"> inner text </ELEMENT>
< ELEMENT ATTRIB="foo"> inner text </ELEMENT>
< ELEMENT ATTRIB="foo"> inner text </ELEMENT>
<ELEMENT>inner text</FOO>
ELEMENT ATTRIB="foo"> inner text </ELEMENT>
<ELEMENT>inner text</ELEMENT>
<ELEMENT>inner text</ELEMENT>
<ELEMENT>inner text</ELEMENT>
<ELEMENT > inner text </ELEMENT>
<ELEMENT > inner text </ELEMENT>
<ELEMENT > inner text </ELEMENT>
<ELEMENT ATTRIB="foo"> inner text </ELEMENT>
<ELEMENT ATTRIB="foo"> inner text </ELEMENT>'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result