use strict;
my $str = 'a
list
you want
to
use
in
a
sql
in
statement';
my $regex = qr/^(.*)$/mp;
my $subst = '\'$1\',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";