re = /^(.*)$/m
str = 'a
list
you want
to
use
in
a
sql
in
statement'
subst = '\'$1\','
result = str.gsub(re, subst)
# Print the result of the substitution
puts result