using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<azurePrefix>https:\/\/%%BLOBCONTAINER%%.blob.core.windows.net)\/(?<containerId>\S+)\/(?<inDir>in)\/(?<path>(\S+\/)*?)(?<filename>[^<>:""/\\\|\?\*]+(\.[^<>:""/\\\|\?\*]+)*)$";
string input = @"https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/Copy.xml
https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log
https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log
https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}