// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(?<azurePrefix>https:\/\/%%BLOBCONTAINER%%.blob.core.windows.net)\/(?<containerId>\S+)\/(?<inDir>in)\/(?<path>(\S+\/)*?)(?<filename>[^<>:"/\\\|\?\*]+(\.[^<>:"/\\\|\?\*]+)*)$"#).unwrap();
let string = "https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/Copy.xml
https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log
https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log
https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}