import re
regex = re.compile(r"^(?<azurePrefix>https:\/\/%%BLOBCONTAINER%%.blob.core.windows.net)\/(?<containerId>\S+)\/(?<inDir>in)\/(?<path>(\S+\/)*?)(?<filename>[^<>:\"/\\\|\?\*]+(\.[^<>:\"/\\\|\?\*]+)*)$", flags=re.MULTILINE)
test_str = ("https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/Copy.xml\n"
"https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log\n"
"https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log\n"
"https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")