import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<azurePrefix>https:\\/\\/%%BLOBCONTAINER%%.blob.core.windows.net)\\/(?<containerId>\\S+)\\/(?<inDir>in)\\/(?<path>(\\S+\\/)*?)(?<filename>[^<>:\"/\\\\\\|\\?\\*]+(\\.[^<>:\"/\\\\\\|\\?\\*]+)*)$";
final String string = "https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/Copy.xml\n"
+ "https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log\n"
+ "https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log\n"
+ "https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}