const regex = /^(?<azurePrefix>https:\/\/%%BLOBCONTAINER%%.blob.core.windows.net)\/(?<containerId>\S+)\/(?<inDir>in)\/(?<path>(\S+\/)*?)(?<filename>[^<>:"/\\\|\?\*]+(\.[^<>:"/\\\|\?\*]+)*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<azurePrefix>https:\\\/\\\/%%BLOBCONTAINER%%.blob.core.windows.net)\\\/(?<containerId>\\S+)\\\/(?<inDir>in)\\\/(?<path>(\\S+\\\/)*?)(?<filename>[^<>:"\/\\\\\\|\\?\\*]+(\\.[^<>:"\/\\\\\\|\\?\\*]+)*)$', 'gm')
const str = `https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/Copy.xml
https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log
https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log
https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}