re = /^(?<azurePrefix>https:\/\/%%BLOBCONTAINER%%.blob.core.windows.net)\/(?<containerId>\S+)\/(?<inDir>in)\/(?<path>(\S+\/)*?)(?<filename>[^<>:"\/\\\|\?\*]+(\.[^<>:"\/\\\|\?\*]+)*)$/m
str = 'https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/Copy.xml
https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log
https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log
https://%%BLOBCONTAINER%%.blob.core.windows.net/tenant2/in/compta/Subdir1/subdir2/couper.log'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end