using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(script|style)[^>]*>[\s\S]*?<\/\1>|<\/?[^>]+>";
string substitution = @"";
string input = @"<div class=""my_class"">
<div class=""copy"">
© 2018 Texto
</div>
</div>
<div class=""my_class"">
<h1>¿como estas?</h1>
<div class=""copy"">
© 2018 Texto
</div>
<script>
function hola(){
}
</script>
<style>
.red{
background-color: red;
}
</style>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}