use strict;
my $str = '<div class="my_class">
<div class="copy">
© 2018 Texto
</div>
</div>
<div class="my_class">
<h1>¿como estas?</h1>
<div class="copy">
© 2018 Texto
</div>
<script>
function hola(){
}
</script>
<style>
.red{
background-color: red;
}
</style>
';
my $regex = qr/<(script|style)[^>]*>[\s\S]*?<\/\1>|<\/?[^>]+>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";