$re = '/<(script|style)[^>]*>[\s\S]*?<\/\1>|<\/?[^>]+>/m';
$str = '<div class="my_class">
<div class="copy">
© 2018 Texto
</div>
</div>
<div class="my_class">
<h1>¿como estas?</h1>
<div class="copy">
© 2018 Texto
</div>
<script>
function hola(){
}
</script>
<style>
.red{
background-color: red;
}
</style>
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;