const regex = /<(script|style)[^>]*>[\s\S]*?<\/\1>|<\/?[^>]+>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(script|style)[^>]*>[\\s\\S]*?<\\\/\\1>|<\\\/?[^>]+>', 'gm')
const str = `<div class="my_class">
<div class="copy">
© 2018 Texto
</div>
</div>
<div class="my_class">
<h1>¿como estas?</h1>
<div class="copy">
© 2018 Texto
</div>
<script>
function hola(){
}
</script>
<style>
.red{
background-color: red;
}
</style>
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);