import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/category\\/(\\w+\\/)?(\\d+)";
final String string = "https://m.aaa.kr/category/outer/55/\n"
+ "https://m.aaa.kr/category/inner/5/\n"
+ "https://m.aaa.kr/product/jacket/3031/category/55/display/1/\n"
+ "https://m.aaa.kr/product/shirts/30/category/5/display/1/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}