import Foundation
let pattern = #"\/category\/(\w+\/)?(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://m.aaa.kr/category/outer/55/
https://m.aaa.kr/category/inner/5/
https://m.aaa.kr/product/jacket/3031/category/55/display/1/
https://m.aaa.kr/product/shirts/30/category/5/display/1/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)