// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/category\/(\w+\/)?(\d+)").unwrap();
let string = "https://m.aaa.kr/category/outer/55/
https://m.aaa.kr/category/inner/5/
https://m.aaa.kr/product/jacket/3031/category/55/display/1/
https://m.aaa.kr/product/shirts/30/category/5/display/1/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}