const regex = /\/category\/(\w+\/)?(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/category\\\/(\\w+\\\/)?(\\d+)', 'g')
const str = `https://m.aaa.kr/category/outer/55/
https://m.aaa.kr/category/inner/5/
https://m.aaa.kr/product/jacket/3031/category/55/display/1/
https://m.aaa.kr/product/shirts/30/category/5/display/1/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}