import re
regex = re.compile(r"\/category\/(\w+\/)?(\d+)")
test_str = ("https://m.aaa.kr/category/outer/55/\n"
"https://m.aaa.kr/category/inner/5/\n"
"https://m.aaa.kr/product/jacket/3031/category/55/display/1/\n"
"https://m.aaa.kr/product/shirts/30/category/5/display/1/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")